Investigating Issues with Update Feed

Incident Report for monday.com

Resolved

The Update Feed issue has been successfully resolved. Please refresh your browser to access the platform. Thank you so much for your patience!
Posted Sep 29, 2025 - 11:30 UTC

Monitoring

We are currently experiencing issues related to Update Feed. Our dedicated team is working to resolve this as quickly as possible!
Posted Sep 29, 2025 - 10:50 UTC
This incident affected: EU (Communication).