Issues with the Activity Log
Incident Report for monday.com
Resolved
The Activity Log issue has been successfully resolved. Please refresh your browser to access the platform. Thank you for your patience
Posted Nov 11, 2024 - 18:34 UTC
Identified
Our team has identified the root cause of the issue with the activity log and is working to resume regular service usage. We will continue to provide updates on their progress.
Posted Nov 11, 2024 - 10:41 UTC
Investigating
We are currently investigating reports of issues related to Activity Log. Our team is looking into this and will provide you with a response as soon as possible.
Posted Nov 11, 2024 - 08:27 UTC
This incident affected: US (Other Functionalities).