Monitoring issues with board creation

Incident Report for monday.com

Resolved

The board creation issue has been successfully resolved. Please refresh your browser to access the platform. Thank you for your patience
Posted Jul 31, 2025 - 07:10 UTC

Monitoring

A fix has been implemented and we are monitoring results to ensure full system stability.
Posted Jul 31, 2025 - 06:59 UTC
This incident affected: EU (Platform) and AUS (Platform).